Worklog First wii portable for final paper

Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
I have but that sadly doesn't fix it

I've found a capacitor that has been removed somehow, ive only spotted it now so unsure when it went off, or even if it gives any problems but I thought I'll share it in the quest to find the problem
It's c23, the one pointed at with the knife
 

Attachments

Last edited:
Joined
Jan 4, 2018
Messages
27
Likes
0
[QUOTE = "wudopecker, post: 34881, member: 4825"] nuevo problema: obtuve el lector de tarjetas micro sd kingston recomendado, con un Samsung evo de 64 gb, pero los malditos juegos de wii todavía no se lanzarán, ¿alguna sugerencia? [/ QUOTE]

Todos tenemos el mismo problema tienen que actualizar ya el portabilizemii urgente
 

Gman

RTFDS
Staff member
.
.
.
.
.
Joined
Feb 25, 2016
Messages
1,058
Likes
2,228
[QUOTE = "wudopecker, post: 34881, member: 4825"] nuevo problema: obtuve el lector de tarjetas micro sd kingston recomendado, con un Samsung evo de 64 gb, pero los malditos juegos de wii todavía no se lanzarán, ¿alguna sugerencia? [/ QUOTE]

Todos tenemos el mismo problema tienen que actualizar ya el portabilizemii urgente
This is an English only forum. Please use english or google translate. Thank you.
 

Timo43

.
Joined
Dec 7, 2019
Messages
54
Likes
13
Location
OH-IO, my basement
[QUOTE = "wudopecker, post: 34881, member: 4825"] nuevo problema: obtuve el lector de tarjetas micro sd kingston recomendado, con un Samsung evo de 64 gb, pero los malditos juegos de wii todavía no se lanzarán, ¿alguna sugerencia? [/ QUOTE]

Todos tenemos el mismo problema tienen que actualizar ya el portabilizemii urgente
This issue was solved by reinstalling portabalize me. There is no need for the devs to update Portablizemii. If this doesn’t solve your issue you can check the troubleshooting trimming guide ( might be able to help ) and after that create a thread. Here is a link to the thread: https://bitbuilt.net/forums/index.p...ve-wii-trimming-and-troubleshooting-faq.2385/
 
Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
[QUOTE = "wudopecker, post: 34881, member: 4825"] nuevo problema: obtuve el lector de tarjetas micro sd kingston recomendado, con un Samsung evo de 64 gb, pero los malditos juegos de wii todavía no se lanzarán, ¿alguna sugerencia? [/ QUOTE]

Todos tenemos el mismo problema tienen que actualizar ya el portabilizemii urgente
reinstalling worked for me, when installing portablizemii i pressed the go back button after doing the "once you’re in the hackmii installer, install BootMii as IOS" instead of the continue button which made wii games not work for me
 
Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
Haven't updated this in over 2 months so here we go:

I wasn't able to make the 6 layer work, neither the 4 layer i had at home. The 6 layer was put to side and the 4 layer was shipped of the BocuD for inspections, he has been a big help over the last couple of months so big props to him! But after getting some neat infrared camera pictures of my board from him he declared it dead. We worked out a deal and he shipped a working one back for me to work on <3

I've been slowly getting all parts in / ordering new ones over the last weeks, i currently posses everything that i need besides a fitting barrel jack for my case. As for the case i currently got a white G-wii printed by again, Bocu, but stupid me send the wrong top half STL so my neighbor was kind enough to print it again on his Ender cr-20, but print difference is huge between Bocu's lol.
JPEG_20200128_143212.jpg
JPEG_20200201_135400.jpg


Currently i have a trimmed Wii with USB connected, Bluetooth reconnected, Display connected and a powermii lite to power it all on. But the issues i have right know is that the bluetooth doesnt work, have tried some stuff with people over at discord but nothing works so far, gonna try rewiring it today or getting a different module from a other wii. Usb also works 50% of the times, guessing because the wires might be a bit long? But if i get everything working im gonna put it all in the case hoping this weekend to finish my project!

edit: Also over the past couple of months i have destroyed a good bit of electronics i would hope to save / fix after this project after i get some more experience under my belt, for example:
Eyoyo driver board, used a hot air gun and got the 40 pin connector off, and soldering a new one is a bitch, havent gotten it to work, so might have destroyed more too
An basic 5" inch screen from ebay, i had it on a box when testing my 6 layer and the controller peace with buttons fell and a exposed wired from the batteries touched which killed it lol
The PMS doesnt work right now because its shorted, Maybe because i used a soldering gun first which was a bit to big, or a shorted wii killed it? havent found out but i've definitely learned to get some good Tools like a hakko 888d, helps a ton X)

Edit 2: I got Bluetooth working and USB seems to be alright too!

I rewired the data lines and used a different Bluetooth module which seemed to do the trick! Thank you all guys so much for helping so much! It's been a blessing :D
 
Last edited:
Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
Smaller update:
Bluetooth broke again, had to be resoldered again to work, maybe I moved the cables a bit? Idk, can I put kapton tape on them to keep them secure? Or would that be a nono?

USB is fully working now, wired had to shortened just slightly it seemed

I've hooked up audio too today! I used nintendo switch speakers with a PAM8403, the sound is alright, nothing fancy, but the issue I currently have that my rightoutup is like 6-7~ times as loud as my left output, and I can't really tell what causes it, switching speakers didn't change anything. Any advice?

The last thing I needed to do is 5v mod my display, but I have looked around a handful of threads here about display modding but I can't find the same motherboard that I have, and one said to be very careful when using a multimeter on them, so does anyone know how to mod mine? To scared to look around after that warning
IMG_20200205_223956.jpg


If that works I'm gonna attempt the vga patches and install everything hopefully this weekend :D
 

GingerOfOz

no wario
Staff member
.
.
.
Joined
Dec 16, 2016
Messages
1,026
Likes
2,249
Location
The Oregon Wildlands
Portables
3
Regarding keeping BT data wires in place, a dab of hot glue on the two wires is a good idea to keep them from moving. Don't put the hot glue over the solder joint, put it up a bit higher so that you can easily tell if the joint gets knocked loose again.

Don't know if I can help much with your audio issue, but that screen driver board is pretty easy to do a low voltage mod on. I run mine off of just 3.3v, you can see how I do it in this thread.
 
Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
Regarding keeping BT data wires in place, a dab of hot glue on the two wires is a good idea to keep them from moving. Don't put the hot glue over the solder joint, put it up a bit higher so that you can easily tell if the joint gets knocked loose again.

Don't know if I can help much with your audio issue, but that screen driver board is pretty easy to do a low voltage mod on. I run mine off of just 3.3v, you can see how I do it in this thread.
I'll try the glue method thanks!

As for the display, I'm looking over your pictures, and did you use hot air? Because I currently don't have a station for that and I'm unsure if I can remove that what I think is an ldo then at the bottom left? Also if I don't use a PMS but a powermii lite, then where do I leave on the removed inductors?
 

Aurelio

ᕕ( ᐛ )ᕗ
Staff member
.
.
.
.
.
.
Joined
Mar 3, 2016
Messages
1,979
Likes
2,644
Portables
2
Removing the inductor where you're supposed to apply 3.3V is enough
 
Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
Well everything was going alright, the display mods works thanks to Aurelio's help after me being stupid lol, the only thing left to do was vga mod and put everything into a case, but it failed "un the priiloader VGA installer and follow the on-screen steps. At the end of the installation it will boot back to the Homebrew Channel." But I booted into Wii menu instead, which I thought was weird but didn't think to much of it so I continued and I guess I should have been worried because I did step 6, load/ install postloader but it was loading and half way it stopped and the screen turned black and the speakers are giving a high beeping noise right now

I'm really frustrated and sad at the same time right now but I'll have to go to work for now, if anyone has an idea let me know but I'm fearing the worst and that I have to start over again :(

Edit: so far Aurelio has helped me, only need to wire vga up but bridged some pins on the Ave, gonna fix that tommorow my back is dead, tysm tho
 
Last edited:
Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
Well that just fixing bridges didn't work, I properly didn't do it properly or some sort but I spent a lot of time doing it, and closely inspecting with a loop if it was gone, but when trying to power it on a lot of smoke came from the ave, also spots that weren't bridged before, not sure what went wrong? Maybe flux getting under it? I have no idea, couldn't fix it either anymore after that so we started over last Sunday

Trimmed my own board, and got it successfully working on my own this time without BocuD's help so little proud of myself.

But here is a glorious video of it working with audio, Bluetooth and USB and display 3.3v modded
https://www.dropbox.com/s/ab545n8fcxpkj9f/Snapchat-600827189.mp4?dl=0

I also managed to fix issues of my other Wii (with bocus ideas as usual lmao )
But audio issues seemed to be because of two not correctly working audio amps, the third seemed to be the charm

Only issue is that another lcd died, it doesn't turn on anymore and I have no idea why sadly

Happy I got so far already again in a short time, everything is going a lot smoother now, wiring to vias generally goes right the first time now for example :))
 
Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
The build is almost done, showed it not close on discord because I had Bluetooth / sticks issues
I fixed those today, the only thing I need to fix is audio, currently I use a pam8403 which has no volume controls so it's stupidly loud, can i hookup this 10k ohm potmeter and if so how? Can't really find a diagram on how to do it
JPEG_20200226_170613.jpg
 

Gman

RTFDS
Staff member
.
.
.
.
.
Joined
Feb 25, 2016
Messages
1,058
Likes
2,228
With that amp, you would need a potentiometer for both audio channels or a dual Gang pot which is 2 pots on one axis. Hook up the middle pin to the L/R audio input, then one side to ground and the other side the audio output from the wii. This is creating a voltage divider to ground to attenuate the audio signal before the amp. Its not ideal, that's why you generally see amps with digital control.
 
Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
With that amp, you would need a potentiometer for both audio channels or a dual Gang pot which is 2 pots on one axis. Hook up the middle pin to the L/R audio input, then one side to ground and the other side the audio output from the wii. This is creating a voltage divider to ground to attenuate the audio signal before the amp. Its not ideal, that's why you generally see amps with digital control.
I'll have a look in the shed to see what we have left, thanks tho!

I was originally gonna use the pam8803 but the left side audio doesn't work for it So I'll give this a try :)

Edit: it worked but sadly doesn't fit :( so I can't close the case
 
Last edited:
Joined
Aug 25, 2019
Messages
105
Likes
81
Location
netherlands
Portables
1
IMG_20200229_165612__01.jpg


Besides in discord I haven't fully shown it off yet, not really satisfied with the looks, not at all tbh

But since there is a deadline on it because of school there wasn't much I could do. I think the sticks not being black is ehh, kinda want to order two black nunchucks to replace it. Also didn't have the time to Bondo / primer / paint it so it's sure ain't the prettiest.

Still sort of proud I got so far tho in the end so I really want to thank all , I will hopefully get my bitbuilt shirt in on time altho I haven't gotten a notification that it's shipped yet, so I can wear it at the presentation.

The issues I currently have is that the red charging board seems to be halve alive, it charges to 7~v but not more, and the led goes completely crazy, sadly can't get a new one in time for the presentation so hopefully that small windows is gonna be enough to show it working
Also I can't get the bottom 2 screws in, they just don't come far enough when using m2 x 8mm, either doing it wrong or gonna get some longer screws.
 
Top