RVLoader v1.6

Joined
Feb 13, 2023
Messages
1
Likes
0
Can I use RVLoader with original discs? I just want to be able to get VGA out of my Wii so that I can use a Rondo HD15 to Scart in order to use my Wii with my Scart Switch. If I were to use RVLoader what kind of VGA cables would I need? Would I have to build my own for Wii? Also would this require an actual hardmod of my Wii?

Sincerely, SomeoneWhoWishesWiiDualWasStillAThing
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
3,719
Likes
2,926
Location
Banana Bender Land, Australia
Portables
6
Can I use RVLoader with original discs? I just want to be able to get VGA out of my Wii so that I can use a Rondo HD15 to Scart in order to use my Wii with my Scart Switch. If I were to use RVLoader what kind of VGA cables would I need? Would I have to build my own for Wii? Also would this require an actual hardmod of my Wii?

Sincerely, SomeoneWhoWishesWiiDualWasStillAThing
No original discs afaik. RVLoader was designed for portables, which never use the disc drive.

And yeah you would have to make your own cable as the H and V sync pins on the AVE don't go anywhere. You'll need to wire them either to a VGA socket, or sever and hijack a connection to the AV out port and use a custom AV cable
 

Sm6413

.
Joined
Feb 15, 2023
Messages
27
Likes
6
Hey, i installed Rvloader on a non-trimmed wii, every game works except Mario Kart, when i start it it tries to create a save file then it says "Unable to read from/write to wii system memory"

I tried completly factory resetting the console, deleting RVLoader and the HBC, then reinstalling it, i tried deleting the save game file etc... but nothing works

Any ideas? Maybe i should get a completed savegame file and put it in my wii?
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
3,719
Likes
2,926
Location
Banana Bender Land, Australia
Portables
6
Hey, i installed Rvloader on a non-trimmed wii, every game works except Mario Kart, when i start it it tries to create a save file then it says "Unable to read from/write to wii system memory"

I tried completly factory resetting the console, deleting RVLoader and the HBC, then reinstalling it, i tried deleting the save game file etc... but nothing works

Any ideas? Maybe i should get a completed savegame file and put it in my wii?
I remember this issue from back in the PortablizeMii days. I thought it had been resolved, but seems Mario Kart still wants to be difficult. Transferring in a new save file used to fix this, so I imagine it will fix it now as well. Smash Bros Brawl can also have this problem btw
 

Sm6413

.
Joined
Feb 15, 2023
Messages
27
Likes
6
I remember this issue from back in the PortablizeMii days. I thought it had been resolved, but seems Mario Kart still wants to be difficult. Transferring in a new save file used to fix this, so I imagine it will fix it now as well. Smash Bros Brawl can also have this problem btw
Thanks bro it works now! I copied the savegame file from my own wii onto it and it works fine now, thanks
 

Sm6413

.
Joined
Feb 15, 2023
Messages
27
Likes
6
Also i have a problem with mkwii, wiimmfi doesnt work... i connected my wii to internet from the system menu, it works fine, but when i try going online on mkwii it just says error 50130, which is a wifi configuration issue from what i've read. I didnt patch out wifi when installing RVLoader so idk what's happening, any ideas? The wii is untrimmed, it doesn't have a DVD drive installed, it has the BT and the WIFI modules installed.
 
Last edited:

Viilmo

.
Joined
Jun 23, 2021
Messages
203
Likes
86
Location
Germany
Portables
1
Also i have a problem with mkwii, wiimmfi doesnt work... i connected my wii to internet from the system menu, it works fine, but when i try going online on mkwii it just says error 50130, which is a wifi configuration issue from what i've read. I didnt patch out wifi when installing RVLoader so idk what's happening, any ideas? The wii is untrimmed, it doesn't have a DVD drive installed, it has the BT and the WIFI modules installed.
Press 1 when you're hovering above the game and enable WiFi
 
Joined
Apr 29, 2020
Messages
86
Likes
106
RVLoader seems to be having an issue with loading patched wbfs files at the moment. It might be fixed in a future release but as of now you can only launch a patched game using another loader such as USB Loader GX.
 

Sm6413

.
Joined
Feb 15, 2023
Messages
27
Likes
6
RVLoader seems to be having an issue with loading patched wbfs files at the moment. It might be fixed in a future release but as of now you can only launch a patched game using another loader such as USB Loader GX.
That's pretty funny cuz i've been trying to load games from usb loader gx all day and i haven't managed to make them work, i tried to install all kind of cios etc but the only thing i get is either a black screen or a message like "an error has occured, press eject to remove the disk etc..."
I also tried wiiflow, same thing...

Any ideas? I tried 2 usb drives, both in WBFS format, both don't work
 
Joined
Apr 29, 2020
Messages
86
Likes
106
I managed to get it to work a few months ago. I am not sure which cios you installed, make sur you follow the guide on https://wii.guide/cios. Try booting a game without a patch and if that works then try booting the patched game.
 

Sm6413

.
Joined
Feb 15, 2023
Messages
27
Likes
6
Did you install the correct CIOS to all 3 slots?
Yes i did, it's probably the 50th time i do all of this since last week and i followed multiple tutorials so i may have put another cios on another slot or idk, is there a way to check all installed cios?
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
3,719
Likes
2,926
Location
Banana Bender Land, Australia
Portables
6
There's a homebrew app for that, but I forget what it's called
 

Sm6413

.
Joined
Feb 15, 2023
Messages
27
Likes
6
There's a homebrew app for that, but I forget what it's called
I completely restored my NAND back to default (theres a program to do it), i did a syscheck before and after doing it, it took me like 2 hours

I reinstalled the 3 cios

And it still doesnt work

I'm going to smash this wii

Edit : i just tried using CFG loader, still black screen... i tested another wii w/ the same usb key and it works fine....
 
Last edited:

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
3,719
Likes
2,926
Location
Banana Bender Land, Australia
Portables
6
I completely restored my NAND back to default (theres a program to do it), i did a syscheck before and after doing it, it took me like 2 hours

I reinstalled the 3 cios

And it still doesnt work

I'm going to smash this wii

Edit : i just tried using CFG loader, still black screen... i tested another wii w/ the same usb key and it works fine....
Did you use ohneschwanzenegger to do it? If not, if you send me a full bootmii NAND backup with the keys.bin I can generate you a completely stock NAND image to flash onto your Wii. AFAIK it's the only way to completely reset a Wii to stock, the other tools always miss something.
 

Sm6413

.
Joined
Feb 15, 2023
Messages
27
Likes
6
Did you use ohneschwanzenegger to do it? If not, if you send me a full bootmii NAND backup with the keys.bin I can generate you a completely stock NAND image to flash onto your Wii. AFAIK it's the only way to completely reset a Wii to stock, the other tools always miss something.
Yes i did use ohneschwanzenegger.

I compared the 2 syschecks before and after putting the new reseted nand, and i can confirm all ios'es were removed.

Then i installed the 3 cios'es (249-250-251) using the tutorial at wii.guide/cios

Then i did a syscheck and i see the 3 cios'es were succesfully installed.

I have around 15 spare wiis with dead drives that i use either for parts or to modify them, i have one which is a similar model, and the same usb key works fine and loads games. Since the wii i'm troubleshooting has been modified a bit : RTC battery relocation+ dvd drive removal(yes it doesnt boot games if i connect the drive, i checked...) + other things, maybe the wii has a problem.

So what i'm going to do is that i'm going to swap parts between the 2 wiis and see if i can confirm the problem is in the wii motherboard itself or if i have another problem, with one of the wifi/bt modules or something else

I think this wii has a very big problem, games dont load or shows "an error has occured, press eject etc.." or shows exception DSI occured , and games doesnt want to save if there isnt already a game save in the wii...


Help me man i'm losing hope

EDIT : I FIXED IT!! remember the part when i said "i tested with a dvd drive still doesnt work"?? I started swapping parts between the 2 wiis and guess what? I SWAPPED THE 2 DVD DRIVES AND NOW IT WORKS!!! maybe dead dvd drive controller board? Idk but it works now...

The games still doesnt want to save though, for mkwii i managed to transfer a savegame file but for animal crossing the savegame manager says i need an existing savegame file... idk what to do

Thanks a lot
 
Last edited:

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
3,719
Likes
2,926
Location
Banana Bender Land, Australia
Portables
6
Yes i did use ohneschwanzenegger.

I compared the 2 syschecks before and after putting the new reseted nand, and i can confirm all ios'es were removed.

Then i installed the 3 cios'es (249-250-251) using the tutorial at wii.guide/cios

Then i did a syscheck and i see the 3 cios'es were succesfully installed.

I have around 15 spare wiis with dead drives that i use either for parts or to modify them, i have one which is a similar model, and the same usb key works fine and loads games. Since the wii i'm troubleshooting has been modified a bit : RTC battery relocation+ dvd drive removal(yes it doesnt boot games if i connect the drive, i checked...) + other things, maybe the wii has a problem.

So what i'm going to do is that i'm going to swap parts between the 2 wiis and see if i can confirm the problem is in the wii motherboard itself or if i have another problem, with one of the wifi/bt modules or something else

I think this wii has a very big problem, games dont load or shows "an error has occured, press eject etc.." or shows exception DSI occured , and games doesnt want to save if there isnt already a game save in the wii...


Help me man i'm losing hope

EDIT : I FIXED IT!! remember the part when i said "i tested with a dvd drive still doesnt work"?? I started swapping parts between the 2 wiis and guess what? I SWAPPED THE 2 DVD DRIVES AND NOW IT WORKS!!! maybe dead dvd drive controller board? Idk but it works now...

The games still doesnt want to save though, for mkwii i managed to transfer a savegame file but for animal crossing the savegame manager says i need an existing savegame file... idk what to do

Thanks a lot
You can bypass that with Savegame Manager GX, or you can install Priiloader and activate the sysmenu hack to remove nocopy protection from save files
 

Sm6413

.
Joined
Feb 15, 2023
Messages
27
Likes
6
You can bypass that with Savegame Manager GX, or you can install Priiloader and activate the sysmenu hack to remove nocopy protection from save files
Thanks a lot, the problem with the saves somehow comes from rvloader, with usb loader gx it can create saves without any problem. Thanks a lot again
 
Top