Worklog The LIGHTNiiNG - BLOCKED

Joined
Jan 11, 2022
Messages
103
Likes
174
Location
Italy
A little update:
I recently started trying to recreate the circuit boards from 4Layertech so that I can easily integrate them to the final PCB. First I started whit the U-AMP, and next i'm going for the GC+2. These two should be the easiest to recreate, in fact I have decided to leave the RVL-PMS-2 for last.
Immagine kicad real.png
 
Joined
Apr 29, 2020
Messages
104
Likes
128
That’s great! Which LCD driver board are you working on (the one sold on 4Layertech)? Also, do you have a version of the Wii motherboard that boots?
 
Joined
Jan 11, 2022
Messages
103
Likes
174
Location
Italy
That’s great! Which LCD driver board are you working on (the one sold on 4Layertech)? Also, do you have a version of the Wii motherboard that boots?
The driver board is the one from 4Layertech.
I’m still working on the wii motherboard, just practicing to be sure to solder GPU, CPU, and RAM in the best way possible
 
Joined
Oct 28, 2022
Messages
16
Likes
9
Location
Planet Zebes
Portables
No portables (Yet)
I don’t know how you people do this. Why are you so smart. How can I get smart?
 
Joined
Jan 11, 2022
Messages
103
Likes
174
Location
Italy
Finally an update and good news:D
In the last weeks i've been training for weeks, trying to learn how to clean, reball, and reflow BGA components. It's was very hard but i managed to find a lot of useful inormations that helped me in the achivement of my main goal. Here are some images of the reworked GPU, and GPU (don't mind the missing pads, these are the components i've been training with):
GPU
IMG_0731.jpg
IMG_0732.jpg

CPU
IMG_0733.jpg
IMG_0734.jpg


Today i finally managed to reflow both of this components and also the RAM, and they got in place so easily.
IMG_0744.jpg
IMG_0745.jpg

I'm so excited right now, can't wait to try to repeat this process on the working components. Hope that everything is going to work
 
Joined
Apr 29, 2020
Messages
104
Likes
128
Time and dedication have started to pay off, congratulations! A step closer to a fully integrated portable
 

MJMT

.
Joined
Apr 16, 2021
Messages
89
Likes
118
Portables
2
That is very exciting progress!
 
Joined
Jan 11, 2022
Messages
103
Likes
174
Location
Italy
So something happened but i’m stuck to a point where the wii seems to turn on but the screen just turns black. Any advice would be great. For now I’m just going to check the connections of the components.
18E28FD3-59A7-4081-84C1-BB229A27D848.jpeg
F40124A3-B35D-4DDF-90D1-1F7A1F6813B9.jpeg
3075C17C-53C3-4E0E-81A6-B98D56DC2200.jpeg
 
Joined
Apr 29, 2020
Messages
104
Likes
128
Can you show us the wiring between the Wii and the display board? Did you enable the VGA patches? Did you test this exact setup but on a trimmed Wii before transplanting parts over?
 
Joined
Jan 11, 2022
Messages
103
Likes
174
Location
Italy
Can you show us the wiring between the Wii and the display board? Did you enable the VGA patches? Did you test this exact setup but on a trimmed Wii before transplanting parts over?
I test every trim before transplanting parts on my pcb. VGA patches are enabled but right now I'm testing the board via AV cable which is connected on the top right side of the pcb
 
Joined
Apr 29, 2020
Messages
104
Likes
128
If VGA patches are enabled you must use VGA otherwise you’ll get a black screen. Try to wire VGA and see if that works out.
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
.
Joined
Feb 5, 2017
Messages
3,960
Likes
3,119
Location
Banana Bender Land, Australia
Portables
6
I'm guessing you put the mode jumper on the underside as well?

If VGA patches are enabled you must use VGA otherwise you’ll get a black screen. Try to wire VGA and see if that works out.
Actually incorrect. If the mode pin is not shorted to 3.3v, composite output will work as normal
 
Joined
Jan 11, 2022
Messages
103
Likes
174
Location
Italy
I'm guessing you put the mode jumper on the underside as well?


Actually incorrect. If the mode pin is not shorted to 3.3v, composite output will work as normal
My mode pin is not shorted to 3.3v. I don't know if this is the problem
 
Joined
Apr 29, 2020
Messages
104
Likes
128
My bad, then I guess the problem comes from somewhere else. I don’t know how you could test your AVE, GPU and CPU connections
 

thedrew

.
.
Joined
Sep 27, 2016
Messages
432
Likes
940
Hmm kind of hard to diagnose since this is your own board redesign. GPU/CPU get warm? Getting proper voltages and no shorts? I would compare the resistances to another known working board just to make sure everything is what it should be.
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
.
Joined
Feb 5, 2017
Messages
3,960
Likes
3,119
Location
Banana Bender Land, Australia
Portables
6
My mode pin is not shorted to 3.3v. I don't know if this is the problem
If the mode pin is not shorted to 3.3v, then composite video should work fine. If it is shorted to 3.3v then only VGA will be outputted.
 
Top