Question Battery Problems

Discussion in 'Other' started by kjc35, Jul 26, 2016.

  1. kjc35 .

    Joined:
    Apr 27, 2016
    Messages:
    46
    Likes Received:
    5
    For awhile now my battery pack (4S 14.8V 5200mah) has been working fine in my Wii Laptop but all of a sudden it wouldn't turn on. From the output ends of the PCM it showed 8.16V but from the direct ends of B1- and B4+ there was 16.17V. Is the PCM blown or is there a way to sort of spark it back like I've seen before? Thanks a ton
     
  2. cheese the tallest memer in town Staff Member . . .

    Joined:
    Mar 2, 2016
    Messages:
    2,486
    Likes Received:
    2,212
    Location:
    Florida
    Try charging the batteries, that usually resets short detection circuits.
     
  3. kjc35 .

    Joined:
    Apr 27, 2016
    Messages:
    46
    Likes Received:
    5
    That's what I tried before, but the chargers red light didn't come on like it usually does
     
  4. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,775
    Likes Received:
    2,436
    Portables:
    2
    Check the voltage across each cell
     
  5. kjc35 .

    Joined:
    Apr 27, 2016
    Messages:
    46
    Likes Received:
    5
    B1: 4.12V
    B2: 3.89V
    B3: 4.07V
    B4: 4.08V
     
  6. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,775
    Likes Received:
    2,436
    Portables:
    2
    The PCM might be broken, but in case you haven't tried yet, try to disconnect the batteries from the PCM and then reconnect them to it. Anyway you should consider using a PCM with an integrated balancing circuit, your batteries should be kept at the same voltage.
     
  7. kjc35 .

    Joined:
    Apr 27, 2016
    Messages:
    46
    Likes Received:
    5

Share This Page

Loading...