Solved Error while running wii game

Joined
Aug 13, 2019
Messages
27
Likes
2
hello , i installed latest RV loader v 1.4 in 2 different wiis and i got same results , first of all homebrew channel becomes upside down ,and when ever i want to run games in rv loader a triple head snakes or something freezes with this error Found HWAccess_ES2 at 000291AB and it wont run my games , by the way i couldn't test game cube game since they won't appear in the menu , i put ISOs in games folder , i am using genuine Samsung EVO micro sd card and Kingston card reader , do you have any idea?
 

Attachments

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,586
Likes
2,007
Location
Banana Bender Land, Australia
Portables
6
The Homebrew Channel being upside down is normal and an intentional thing that we can't work around. I can't help with the error code, but I can help with the GC games not showing up. Have you followed the correct file structure? It should be:

Code:
USB://
     games/
          Batman Begins/
               game.iso
          Game Description/
               game.iso
               disc2.iso
All Gamecube ISO files need to be in their own folder within the games folder, and the ISO files themselves must be named "game.iso". You may need to enable file extensions in Windows explorer to do this.
 
Joined
Aug 13, 2019
Messages
27
Likes
2
The Homebrew Channel being upside down is normal and an intentional thing that we can't work around. I can't help with the error code, but I can help with the GC games not showing up. Have you followed the correct file structure? It should be:

Code:
USB://
     games/
          Batman Begins/
               game.iso
          Game Description/
               game.iso
               disc2.iso
All Gamecube ISO files need to be in their own folder within the games folder, and the ISO files themselves must be named "game.iso". You may need to enable file extensions in Windows explorer to do this.
thanks for your helps gamecube worked just fine now the real problem would be that error on wii games!
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,586
Likes
2,007
Location
Banana Bender Land, Australia
Portables
6
Is the BT module present? If not, have you enabled BT emulation for the Wii games you're trying to play?
 
Joined
Aug 13, 2019
Messages
27
Likes
2
Is the BT module present? If not, have you enabled BT emulation for the Wii games you're trying to play?
actually i am testing on an untrimmed wii every module is present and i have enabled that option you are saying , my guess is its incompatibility of my micro sd card but its a genuine card i've checked with samsung app for authenticity and for the kingston it looks very high quality to me , i dont know whats the reason ? gamecube games are just fine though !
 
Joined
Jun 23, 2021
Messages
113
Likes
19
Location
Germany
Portables
None (yet)
Is the BT module present? If not, have you enabled BT emulation for the Wii games you're trying to play?
You can emulate that? Does that mean i can play wii games if the BT module isnt present?
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,586
Likes
2,007
Location
Banana Bender Land, Australia
Portables
6
You can emulate that? Does that mean i can play wii games if the BT module isnt present?
Yes, RVLoader features Aurelio's updated GC2Wiimote patch that removes the need for the BT module to boot Wii games, and allows emulation of Wiimote controls ingame via Gamecube controller mapping. It works with any GC controller, but the GC+2.0 has extra buttons specifically for this.

actually i am testing on an untrimmed wii every module is present and i have enabled that option you are saying , my guess is its incompatibility of my micro sd card but its a genuine card i've checked with samsung app for authenticity and for the kingston it looks very high quality to me , i dont know whats the reason ? gamecube games are just fine though !
I'm afraid I have no idea then. Have you tested more than one Wii game to see if it's just a faulty image? Have you tried deleting the RVLoader files on the card and redownloading a fresh set? That used to fix PortablizeMii issues sometimes.
 
Joined
Aug 13, 2019
Messages
27
Likes
2
Yes, RVLoader features Aurelio's updated GC2Wiimote patch that removes the need for the BT module to boot Wii games, and allows emulation of Wiimote controls ingame via Gamecube controller mapping. It works with any GC controller, but the GC+2.0 has extra buttons specifically for this.


I'm afraid I have no idea then. Have you tested more than one Wii game to see if it's just a faulty image? Have you tried deleting the RVLoader files on the card and redownloading a fresh set? That used to fix PortablizeMii issues sometimes.
i am clueless i thought forums are more active than this !
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,586
Likes
2,007
Location
Banana Bender Land, Australia
Portables
6
Even if they were more active, this is a pretty specific issue. Hiidra is a very new software still in development, and there's no troubleshooting manual for it. Only @Aurelio could really know what these error codes might mean, and he's quite a busy lad so he isn't always here.

We could try looking back at your install process. Seeing as it's happened to 2 different Wiis and doesn't seem to be a common issue for other people, it's possible that you've done something differently, or maybe your install media has an issue. Have you re-downloaded the RVLoader files from the github like I suggested before? It's probably worth booting RVLoader into safe mode and running the installer again with fresh files regardless. You get into safe mode by holding L+R+Z when turning the Wii on.

I'm trying to think of more possible things to ask......
Which USB port are you using? Have you tried using the other port?
When you did banner bomb to install the HBC, did you install bootmii as an IOS?
Have you made sure the Wiis are updated to 4.3 firmware?
What region are these Wiis running on? The letter after the firmware version number in the system settings tells the region.
You also didn't answer my question of how many different Wii games you have tried to run. Some specific games have had issues before and needed special patching.
What video output are you using? It probably doesn't matter, but I'm trying to get an idea of what's going on.
Do you have any other microSD cards you can try? Maybe the card you're using is faulty.
 
Joined
Aug 13, 2019
Messages
27
Likes
2
-yes i had downloaded twice from github repository and the results was the same.
-the USB port i used was the one on the bottom when you put wii horizontally , the one that is the nearest to ground , i changed it in order to see if there will be a change but this time the whole rvloader didnt boot !
-yes i did install bootmii as an ios there was an error in all 3 systems (including the one i trimmed ) while installing HBC that said i can only install bootmi as an ios meaning that i couldnt install it in other form i suppose! it was a red error but i did install as an ios .
-yes all 3 of them are updated to the latest 4.3 firmware.
-2 of them are PAL one of them is NTSC-u
-i have tried with 5 wii games all of them get stuck on that 3 snake splash screen.
-i am outputting my video from YPbPr in 480p mode .
-the only Genuine micro sd card that i have from samsung is this one its 128gb ,i have sandisk microsd card too but i didnt test it since i thought a genuine samsung card will perform better compatibility wise , since they arent cheap around here the option of buying another one isnt available for me .
 
Joined
Aug 13, 2019
Messages
27
Likes
2
Even if they were more active, this is a pretty specific issue. Hiidra is a very new software still in development, and there's no troubleshooting manual for it. Only @Aurelio could really know what these error codes might mean, and he's quite a busy lad so he isn't always here.

We could try looking back at your install process. Seeing as it's happened to 2 different Wiis and doesn't seem to be a common issue for other people, it's possible that you've done something differently, or maybe your install media has an issue. Have you re-downloaded the RVLoader files from the github like I suggested before? It's probably worth booting RVLoader into safe mode and running the installer again with fresh files regardless. You get into safe mode by holding L+R+Z when turning the Wii on.

I'm trying to think of more possible things to ask......
Which USB port are you using? Have you tried using the other port?
When you did banner bomb to install the HBC, did you install bootmii as an IOS?
Have you made sure the Wiis are updated to 4.3 firmware?
What region are these Wiis running on? The letter after the firmware version number in the system settings tells the region.
You also didn't answer my question of how many different Wii games you have tried to run. Some specific games have had issues before and needed special patching.
What video output are you using? It probably doesn't matter, but I'm trying to get an idea of what's going on.
Do you have any other microSD cards you can try? Maybe the card you're using is faulty.
i forgot to use reply while typing so i did this in order to get you notified !
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,586
Likes
2,007
Location
Banana Bender Land, Australia
Portables
6
-yes i had downloaded twice from github repository and the results was the same.
-the USB port i used was the one on the bottom when you put wii horizontally , the one that is the nearest to ground , i changed it in order to see if there will be a change but this time the whole rvloader didnt boot !
-yes i did install bootmii as an ios there was an error in all 3 systems (including the one i trimmed ) while installing HBC that said i can only install bootmi as an ios meaning that i couldnt install it in other form i suppose! it was a red error but i did install as an ios .
-yes all 3 of them are updated to the latest 4.3 firmware.
-2 of them are PAL one of them is NTSC-u
-i have tried with 5 wii games all of them get stuck on that 3 snake splash screen.
-i am outputting my video from YPbPr in 480p mode .
-the only Genuine micro sd card that i have from samsung is this one its 128gb ,i have sandisk microsd card too but i didnt test it since i thought a genuine samsung card will perform better compatibility wise , since they arent cheap around here the option of buying another one isnt available for me .
The bootmii error is normal. Only the first revision (6 layer) Wiis support boot2 injection, so installing as an IOS is the norm. I asked because some people accidentally skip that step and run into trouble later. Aside from trying that sandisk microSD card you have, I'm kinda out of ideas.

The issue is present across multiple systems of different regions, so the only common factors I can see are the microSD card and the Kingston adapter. Do you have any other regular USB drives that you can use to test? They won't be as fast, but that's the only thing I can think of to continue troubleshooting.

EDIT: Actually one other possible cause, how have you set up your Wii games? Are they in WBFS format and have no spaces in the filename?
 
Joined
Aug 13, 2019
Messages
27
Likes
2
The bootmii error is normal. Only the first revision (6 layer) Wiis support boot2 injection, so installing as an IOS is the norm. I asked because some people accidentally skip that step and run into trouble later. Aside from trying that sandisk microSD card you have, I'm kinda out of ideas.

The issue is present across multiple systems of different regions, so the only common factors I can see are the microSD card and the Kingston adapter. Do you have any other regular USB drives that you can use to test? They won't be as fast, but that's the only thing I can think of to continue troubleshooting.

EDIT: Actually one other possible cause, how have you set up your Wii games? Are they in WBFS format and have no spaces in the filename?
these are my wbfs games in a folder named wbfs and besides the gunslinger others are named without space.
and for other usb drive i only have usb 3 adata and patrion and also usb2 patriot none of them are compatible , @Aurelio should have mentioned something somewhere about this error ! but this forums looks like a labyrinth to me when im trying to solve something
 

Attachments

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,586
Likes
2,007
Location
Banana Bender Land, Australia
Portables
6
File structure looks fine to me. I'm afraid my usefulness has just about run out. When you say your other USB drives are incompatible, does this mean you've tested them before and they all had issues?
 
Joined
Aug 13, 2019
Messages
27
Likes
2
File structure looks fine to me. I'm afraid my usefulness has just about run out. When you say your other USB drives are incompatible, does this mean you've tested them before and they all had issues?
no i have not but since compatibilty is very narrow i didnt find my usb flash drives on the list so i assume they wont run!
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,586
Likes
2,007
Location
Banana Bender Land, Australia
Portables
6
RVLoader is compatible with many drives, but there are also several specific drives that don't work and require special software handling to be added. The Kingston adapter has proven to be the drive with the best reliability, and is also very affordable and compact so we recommend that one above all others, but it isn't the only drive that will work. We just don't have enough data on which other drives out there work reliably to expand the compatibility list yet. We'd need a few dozen people buying the same drive from multiple suppliers and confirming reliable full function on multiple systems.

By all means please do test out any other drives you have, with some luck at least one should work.
 
Joined
Aug 13, 2019
Messages
27
Likes
2
RVLoader is compatible with many drives, but there are also several specific drives that don't work and require special software handling to be added. The Kingston adapter has proven to be the drive with the best reliability, and is also very affordable and compact so we recommend that one above all others, but it isn't the only drive that will work. We just don't have enough data on which other drives out there work reliably to expand the compatibility list yet. We'd need a few dozen people buying the same drive from multiple suppliers and confirming reliable full function on multiple systems.

By all means please do test out any other drives you have, with some luck at least one should work.
well i every time i see your replies i get the feeling that maybe i have done something wrong since i am known to myself to be that kind of person , but again if the case is wrong instalation why does gamecube work? and about affordability of kingston reader cards i should tell you they are not available in every country , i myself imported 20 from China since there wasn't any trace of it at all in my country , everybody sold out that card reader ,and about usb ports which one is meant for use with rvloader ? since if i change it from bottom to top it wont boot at all ! i will give my cards a try tonight (in my country) to see if anything changes i'll let you know for future references
EDIT/UPDATE:
i have tested with a 16gb adata usb 3 and it worked just fine !!!
thats unfortunate though since i have paid alot for 128gb samsung evo card i dont know if its samsung or kingston which is faulty in both cases i will be hopeless since i paid alot for importing kingston card readers too i am planning on testing sandisk micro sd cards to see if i could rule out kingstone card reader from being faulty if it runs the game then my samsung is faulty if not i dont know if its compatibility issue with sandisk card or the card reader is faulty ! i should mention that kingstone card readers i bought came in bulk not in genuine package of kingston , its high quality material wise though!
 
Last edited:
Joined
Aug 13, 2019
Messages
27
Likes
2
EUREKA ! EUREKA ! EUREKA !
idid resolve the problem, since my sd card is 128GB i couldn't format it within windows so i used Easeus software but every time i formatted the drive as logical instead of primary i don't pay attention to details sometimes . not only that i did reformat it after creating new partition to set it to 32kb cluster fat32 and voila it booted wii games the only thing made me sure that i did good with setting up the sd card was gamecube games running perfectly and BTW that snake thing isn't an error it just says what it is doing while running games every other time it froze on that splash screen but not this time !
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
2,586
Likes
2,007
Location
Banana Bender Land, Australia
Portables
6
EUREKA ! EUREKA ! EUREKA !
idid resolve the problem, since my sd card is 128GB i couldn't format it within windows so i used Easeus software but every time i formatted the drive as logical instead of primary i don't pay attention to details sometimes . not only that i did reformat it after creating new partition to set it to 32kb cluster fat32 and voila it booted wii games the only thing made me sure that i did good with setting up the sd card was gamecube games running perfectly and BTW that snake thing isn't an error it just says what it is doing while running games every other time it froze on that splash screen but not this time !
Well now we know what that error was for lul. We recommend using guiformat by RidgeCrop for formatting large drives to FAT32, but I don't think anyone ever thought to specifiy partition type for other software. Good catch, we'll know for next time this crops up!
 
Top