Question Wii plays VC and it shows up like this. how to fix

Joined
Feb 11, 2020
Messages
84
Likes
91
Location
Thailand
I can play gc and wii normally, but I play vc and it's like this. how to fix it thanks in advance (Sorry for my language. I use google translate)
wii vc01.jpg
wii vc02.jpg
wii vc03.jpg
wii vc04.jpg
wii vc05.jpg
 

Stitches

2 and a Half Dollarydoos
Staff member
.
.
Joined
Feb 5, 2017
Messages
3,808
Likes
3,001
Location
Banana Bender Land, Australia
Portables
6
Joined
Feb 11, 2020
Messages
84
Likes
91
Location
Thailand
Check for continuity between all the ground legs on MX, and all the 3.3v legs. I've had some trims where some of the 3.3v legs were islanded by the trim and needed to be reconnected to 3.3v.
Thanks, I'll try the measurements again.
 
Joined
Feb 11, 2020
Messages
84
Likes
91
Location
Thailand
I have tried to measure all continuity, both the ground pin, the 3.3 volt pin are normal.
 

RoseDagger

.
2021 2nd Place Winner
Joined
Jan 15, 2021
Messages
45
Likes
95
Location
Not quite socialist North Europe
Portables
GB Adwiince v2
the 3.3 volt pin are normal.
Hmmm, are you sure about the 4 voltage pins? I see that you have connected pin 24 and 25 together, though you are not powering them directly based on your images.
Pin 27 and 17 are connected on the internal 3.3v plane on the mx pcb, but 25 is not connected directly to the 3.3v plane, but rather through the R62 resistor. So there is continuity, but there should be a high resistance by default between pin 27 and pin 25. Try to power pin 25 and 24 directly to 3.3v instead of going through that resistor and see if that works?
 
Last edited:
Joined
Feb 11, 2020
Messages
84
Likes
91
Location
Thailand
Hmmm, are you sure about the 4 voltage pins? I see that you have connected pin 24 and 25 together, though you are not powering them directly based on your images.
Pin 27 and 17 are connected on the internal 3.3v plane on the mx pcb, but 25 is not connected directly to the 3.3v plane, but rather through the R62 resistor. So there is continuity, but there should be a high resistance by default between pin 27 and pin 25. Try to power pin 25 and 24 directly to 3.3v instead of going through that resistor and see if that works?
wii vc022.jpg

Thanks, at this point I've tried this. But it's still the same.
 
Joined
Feb 11, 2020
Messages
84
Likes
91
Location
Thailand
I checked the continuity of pin 11,12,13,14, is it normal, or should I try to replace the new MX chip?
wii vc011.jpg
 
Top