Release Wii native VGA - version 1.4

Discussion in 'Wii' started by Aurelio, May 27, 2018.

  1. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    No ETA, but it’s entirely possible, I just didn’t care much about doing it :D
    I will look into it later
     
    Predue89 likes this.
  2. Koksi_90 .

    Joined:
    Jan 30, 2018
    Messages:
    83
    Likes Received:
    82
    Location:
    Austria
    Portables:
    2
    yeah, take your time :-D
    It is not a must have feature.
     
  3. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    This is untested, but I think it should work. To use this patch, unzip the "hacks_hash.ini" file in /apps/priiloader/ on your USB drive (create the folder if needed), then boot priiloader, go in the "System Hacks" menu and enable the "Force VGA" patch. Then save and try booting the system menu
     

    Attached Files:

    Predue89, Koksi_90 and thedrew like this.
  4. thedrew .

    Joined:
    Sep 27, 2016
    Messages:
    78
    Likes Received:
    103
    Is this to use your vga patch to access the system menu? Or to enable 480p through homebrew rather than the system menu you mentioned a couple posts ago in response to my question? And thank you for this! I will try this patch as well!
     
  5. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    It is to enable VGA in the system menu. The homebrew will take a bit of time to do, but if this patch works you should be able to use the system menu to enable 480p, so the homebrew is not needed anymore
     
    Predue89 and Koksi_90 like this.
  6. Koksi_90 .

    Joined:
    Jan 30, 2018
    Messages:
    83
    Likes Received:
    82
    Location:
    Austria
    Portables:
    2
    REALLY?
    You're awesome!!!
    I'will test this tomorrow
    Thank you so much, you're a really great man
     
    jefflongo and Aurelio like this.
  7. thedrew .

    Joined:
    Sep 27, 2016
    Messages:
    78
    Likes Received:
    103
    @Aurelio

    Well, I "Forced VGA" and get just a black screen when trying to go to the system menu unfortunately. It didn't work for me but maybe somebody else it could work for? Like Koski_90 said, no rush of course, but thank you for trying!
     
  8. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    Hmmm I might have set something wrongly. As I said, ot was untested. I will check the patch tomorrow, maybe I made a stupid mistake
     
    thedrew likes this.
  9. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    I have verified the patch once again and it seems correct. @thedrew can you give me details on your current setup? Does everything else work?
    Also @Koksi_90 can you try it as well? I wonder if the patch requires 480p already enabled. In that case I would have to make that homebrew I was talking about previously
     
  10. thedrew .

    Joined:
    Sep 27, 2016
    Messages:
    78
    Likes Received:
    103
    @Aurelio

    I'm getting the RGB signal from the array of large silver capacitors on the end of the Wii motherboard. I'm then getting H and V directly from the AV chip from your pinout. I also followed your guide to enable the VGA patch in priiloader and also enabled the force VGA option as well for the system menu to get 480i.

    I'm using this screen.
    https://www.ebay.com/itm/Controller...948713&hash=item1a34abf53b:g:ZK0AAOSwC6har14q

    Other than my image being a little glitchy, possibly from not setting the console to 480p after restoring it, everything still works except the system menu as Im just getting a black screen. I'm trying to boot it from priiloader and choosing to launch the system menu. It works on the same screen through composite, just not VGA.
     
  11. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    Hang on you mean that the system menu works for you in composite even with the patch enabled? Do you have the mode pin set to 3.3V?
     
  12. Koksi_90 .

    Joined:
    Jan 30, 2018
    Messages:
    83
    Likes Received:
    82
    Location:
    Austria
    Portables:
    2
    give me an hour to try that, but will this also activate VGA in Priiloader?
    Because I have always a blackscreen in Priiloader
     
  13. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    Uhm VGA in priiloader should already work. Is anybody else having the same issue?
    Koksi try reinstalling the VGA patched priiloader.
     
  14. Koksi_90 .

    Joined:
    Jan 30, 2018
    Messages:
    83
    Likes Received:
    82
    Location:
    Austria
    Portables:
    2
    This is not so easy :(
    .I have to do that blind, because my composite is broken and everything else is working :D.
    So i think i will try that on my second wii
     
  15. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    Run the installer from the VGA patched postloader. It should be in VGA
     
  16. thedrew .

    Joined:
    Sep 27, 2016
    Messages:
    78
    Likes Received:
    103
    Sorry I should have been more specific. I have to desolder my wire from 3.3v to mode and then composite works.

    Priiloader works for me in VGA btw :D
     
  17. Koksi_90 .

    Joined:
    Jan 30, 2018
    Messages:
    83
    Likes Received:
    82
    Location:
    Austria
    Portables:
    2
    it shows "no sync" for me :O
    But every game is working for me.
    I am using the Good Dalian 5" Display
     
  18. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    That's weird. Do other homebrew work in VGA for you?
     
  19. Koksi_90 .

    Joined:
    Jan 30, 2018
    Messages:
    83
    Likes Received:
    82
    Location:
    Austria
    Portables:
    2
    Yes, i tried your GC+ App, Classic+ App, Priiloader VGA Installer,......
    Should i try to reinstall the Priiloader VGA?
     
  20. Aurelio The Fixer ᕕ( ᐛ )ᕗ Staff Member . . . . .

    Joined:
    Mar 3, 2016
    Messages:
    1,745
    Likes Received:
    2,365
    Portables:
    2
    Yes
     

Share This Page

Loading...