Redream for RetroPie game issues


Jan 22, 2023
Is it just me or does Redream have performance issues with RetroPie? I'm running a RPI 4 Model B with 4GB RAM. Nothing unusual in config.txt, using Redream from the pre built binary.

All 3D games played with Dreamcast have black squares flickering on and off, making it unplayable. This also happens with lr-flycast and I couldn't get Reicast to open anything anyway.

I've checked on both battery power and wall outlet. Also tried with and without overclock and using the fake gl drivers on and off. I've tried gdi and cdi rom files. Also tried all resolutions within Redream.

I've tried the games people on YT use to show like Dynamite Cop (which appears flawless) but for me I get these black squares / triangles flickering everywhere. Also there are small lines vertically which is noticable during game loading.

Marvel vs Capcom has no black squares or triangles but the vertical lines are still there.
Tony Hawks 2 in menus has the vertical lines and in game the black squares / triangles.

I'm sure this was working before but didn't really explore Dreamcast so can't say for certain if I had a known good config.

This is a pretty fresh install using retropie-buster-4.8 direct from then flashed with imager so not sure.]

OK something is wrong here, now PPSSPP has the same issue as redream. Trying a game that was fine before (GTA Vice City Stories) it's got hte same issue as Redream in a slightly different format.

Same issue with N64 now also which was very much OK before.

No issues with emulators like Mega Drive or SNES.

*currently - flashing new retropie image and returning to stock to verify issues.

* i think my graphics chip is fried, games now have the described issue but only seems to affect 3d games.

The bad news is something is wrong with this pi now, removed all peripherals and add-ons and yep 3d rendering is borked.
- NOTE TO SELF. do not be careless with power supplies.

Tried latest Raspberry Pi OS, same issues. Tried various power supplies, same issues. Tried alternative HDMI slot, same issues.


Last edited: