Solved C stick axis flipped and decreased sensitivity? (Maybe GC+)

Joined
Sep 9, 2016
Messages
19
Likes
12
Location
Home in New York City, school in Chicago
Hello all,

Today I was wiring up my controls to my new GC+ board and found, to my great surprise, that while everything else works like a charm my C-stick appears to have the X and Y axis flipped, both with very decreased sensitivity. I followed the gamecube joystick pinout for my wiring and have checked again and again - according to the joystick pinout I'm wiring this up right (its not hard to check, theres only four wires). What could be causing this? Could it be the GC+? I do not have an alternate controller board to test this on, but I will try to test with a normal board to see if its a problem with the GC+. I'm stumped, but does anyone have any ideas? Maybe the GC+ is trying to calibrate my joystick like a 3DS slider?
 

Aurelio

ᕕ( ᐛ )ᕗ
Staff member
.
.
.
.
.
.
Joined
Mar 3, 2016
Messages
2,117
Likes
2,801
Portables
2
If both X and Y axes are flipped it could be that either you placed it rotated by 180° with respect to its original position or that you inverted GND and 3.3V on it.
Whatever is the cause you can use the configuration homebrew (create a directory named "GC+ Config" under your "apps" folder and then place in there "wii_ControllerConfig.dol" renamed as "boot.dol") to flip the axes.
Run it and go in the "Sticks range and invert settings", do a couple full rotations on both your sticks and then with the DPad enable "Invert CX" and "Invert CY".
Also since you are using standard sticks you can try decreasing the dead zone in the "Dead zone setting" menu.

Take a look at this video as a reference:

Let me know if that works :)
 
Joined
Sep 9, 2016
Messages
19
Likes
12
Location
Home in New York City, school in Chicago
Holy shit! That was incredibly useful!

I downloaded the gc+ controller config homebrew (for gamecube) onto my SD card running swiss, launched it, and messed with the ranges and sure enough, set the ranges to get my C-stick functioning the way it's meant to (I hope! I still have to switch x and y but I don't have a soldering iron on me so I will do that later) Because of the changes I had to increase my deadzone a bit because the C-stick was now picking up movements because I set it to be so much more sensitive, set the new deadzone to 55. Still wish I could figure out where the source of this issue is but the software fix is handling it well.

This is unrelated, and may not be the best place to post but I cannot access the update feature in the gc+ controller config - I downloaded the gc+update.bin file onto the root of the SD card on my gamecube, but when I try to update I get the "Can't read filer" error. Mario Kart double dash isn't sensing my main stick at all and I think the update may fix it (because the log says the update fixes certain games not registering movements from the stick). Do I have to place the bin file in a different location on the gamecube?
 

Aurelio

ᕕ( ᐛ )ᕗ
Staff member
.
.
.
.
.
.
Joined
Mar 3, 2016
Messages
2,117
Likes
2,801
Portables
2
This is unrelated, and may not be the best place to post but I cannot access the update feature in the gc+ controller config - I downloaded the gc+update.bin file onto the root of the SD card on my gamecube, but when I try to update I get the "Can't read filer" error. Mario Kart double dash isn't sensing my main stick at all and I think the update may fix it (because the log says the update fixes certain games not registering movements from the stick). Do I have to place the bin file in a different location on the gamecube?
Oh sorry, I assumed you were on a Wii. Are you using an SDGecko for the SD card?
 
Joined
Sep 9, 2016
Messages
19
Likes
12
Location
Home in New York City, school in Chicago
I'm using a WASP fusion using the swiss firmware. Do you think the mariokart issue could be fixed from this update?

Also to clarify from before my x and y axis are SWAPPED not inverted, which is why I cannot fix that yet using the firmware, I'll just connect my Y axis wire to the x axis pin on the chip and vice versa once I have access to a soldering station.
 

Aurelio

ᕕ( ᐛ )ᕗ
Staff member
.
.
.
.
.
.
Joined
Mar 3, 2016
Messages
2,117
Likes
2,801
Portables
2
I'm using a WASP fusion using the swiss firmware. Do you think the mariokart issue could be fixed from this update?
Yes the update should fix this.
The configuration homebrew can't load the update file from the WASP SD slot, but only from a SD Gecko. If you don't have one tell me and I will upload a configuration homebrew with the update file hardcoded in it.

Also to clarify from before my x and y axis are SWAPPED not inverted, which is why I cannot fix that yet using the firmware, I'll just connect my Y axis wire to the x axis pin on the chip and vice versa once I have access to a soldering station.
Yes, in this case you have to swap the two wires. Current firmware doesn't include a swapping feature, sorry.
 
Joined
Sep 9, 2016
Messages
19
Likes
12
Location
Home in New York City, school in Chicago
I don't have an SD Gecko, and I would really, really appreciate that.

Thank you so much for all of this, this has been a really obscure problem and I don't know how I would have solved this with a normal controller board!
 

Aurelio

ᕕ( ᐛ )ᕗ
Staff member
.
.
.
.
.
.
Joined
Mar 3, 2016
Messages
2,117
Likes
2,801
Portables
2
I don't have an SD Gecko, and I would really, really appreciate that.

Thank you so much for all of this, this has been a really obscure problem and I don't know how I would have solved this with a normal controller board!
Try this one :)
 

Attachments

tyE

.
Joined
May 2, 2017
Messages
17
Likes
1
So my controls work outside of the configuration app . Any solutions? I needed to invert my y axis but whenever I enter the configuration for gc+ none of my controls work

Nvm figured out my prob


But now my wii just sits on a loading screen lol
 
Last edited:

Aurelio

ᕕ( ᐛ )ᕗ
Staff member
.
.
.
.
.
.
Joined
Mar 3, 2016
Messages
2,117
Likes
2,801
Portables
2
So my controls work outside of the configuration app . Any solutions? I needed to invert my y axis but whenever I enter the configuration for gc+ none of my controls work
Are you using the DPAD to move in the configurator's menu?
 
Top